In short
- CVE-2014-4660 is a MEDIUM (CVSS 5.5) vulnerability affecting ansible, ansible (redhat).
- Chance of exploitation in the next 30 days (EPSS): 0.38%, higher than 32.4% of all vulnerabilities.
- Fix: update to 1.5.5 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible PyPI | < 1.5.5
| 1.5.5
|
| ansible | < 1.5.5
| 1.5.5
|
Description
Ansible before 1.5.5 constructs filenames containing user and password fields on the basis of deb lines in sources.list, which might allow local users to obtain sensitive credential information in opportunistic circumstances by leveraging existence of a file that uses the deb http://user:pass@server:port/ format.
NVD description
Ansible before 1.5.5 constructs filenames containing user and password fields on the basis of deb lines in sources.list, which might allow local users to obtain sensitive credential information in opportunistic circumstances by leveraging existence of a file that uses the "deb http://user:pass@server:port/" format.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free