In short
- CVE-2014-4678 is a CRITICAL (CVSS 9.8) vulnerability affecting ansible, ansible (redhat).
- Chance of exploitation in the next 30 days (EPSS): 5.2%, higher than 92.5% of all vulnerabilities.
- Fix: update to 1.6.4 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible PyPI | < 1.6.4
| 1.6.4
|
| ansible | < 1.6.4
| 1.6.4
|
Description
The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-4657.
NVD description
The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-4657.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free