In short
- CVE-2014-4966 is a CRITICAL (CVSS 9.8) vulnerability affecting ansible, ansible (redhat).
- Chance of exploitation in the next 30 days (EPSS): 3.5%, higher than 89.3% of all vulnerabilities.
- Fix: update to 1.6.7 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible PyPI | < 1.6.7
| 1.6.7
|
| ansible | < 1.6.7
| 1.6.7
|
Description
Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings, and does not prevent remote data with "{{" substrings, which allows remote attackers to execute arbitrary code via (1) crafted lookup('pipe') calls or (2) crafted Jinja2 data.
NVD description
Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings, and does not prevent remote data with "{{" substrings, which allows remote attackers to execute arbitrary code via (1) crafted lookup('pipe') calls or (2) crafted Jinja2 data.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free