In short
- CVE-2014-4967 is a CRITICAL (CVSS 9.8) vulnerability affecting ansible, ansible (redhat).
- Chance of exploitation in the next 30 days (EPSS): 3.5%, higher than 89.3% of all vulnerabilities.
- Fix: update to 1.6.7 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible PyPI | < 1.6.7
| 1.6.7
|
| ansible | < 1.6.7
| 1.6.7
|
Description
Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote attackers to execute arbitrary code by leveraging access to an Ansible managed host and providing a crafted fact, as demonstrated by a fact with (1) a trailing " src=" clause, (2) a trailing " temp=" clause, or (3) a trailing " validate=" clause accompanied by a shell command.
NVD description
Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote attackers to execute arbitrary code by leveraging access to an Ansible managed host and providing a crafted fact, as demonstrated by a fact with (1) a trailing " src=" clause, (2) a trailing " temp=" clause, or (3) a trailing " validate=" clause accompanied by a shell command.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free