In short
- CVE-2014-4994 is a MEDIUM (CVSS 5.5) vulnerability affecting gyazo, gyazo (gyazo project).
- Chance of exploitation in the next 30 days (EPSS): 0.48%, higher than 41.4% of all vulnerabilities.
- Fix: update to 2.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| gyazo RubyGems | ≥ 1.0.0, < 2.0.0
| 2.0.0
|
| gyazo | = 1.0.0
| No fix yet |
Description
lib/gyazo/client.rb in the gyazo gem 1.0.0 for Ruby allows local users to write to arbitrary files via a symlink attack on a temporary file, related to time-based filenames.
NVD description
lib/gyazo/client.rb in the gyazo gem 1.0.0 for Ruby allows local users to write to arbitrary files via a symlink attack on a temporary file, related to time-based filenames.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free