In short
- CVE-2014-5251 is a MEDIUM (CVSS 4.9) vulnerability affecting keystone, keystone (openstack).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.7% of all vulnerabilities.
- Fix: update to 8.0.0a0 or later.
| Package | Affected versions | Patched versions |
|---|
| keystone PyPI | < 8.0.0a0
| 8.0.0a0
|
| keystone | = 2014.1= 2014.1.2= juno-1= juno-2
| No fix yet |
Description
The MySQL token driver in OpenStack Identity (Keystone) 2014.1.x before 2014.1.2.1 and Juno before Juno-3 stores timestamps with the incorrect precision, which causes the expiration comparison for tokens to fail and allows remote authenticated users to retain access via an expired token.
NVD description
The MySQL token driver in OpenStack Identity (Keystone) 2014.1.x before 2014.1.2.1 and Juno before Juno-3 stores timestamps with the incorrect precision, which causes the expiration comparison for tokens to fail and allows remote authenticated users to retain access via an expired token.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free