In short
- CVE-2014-8683 is a MEDIUM (CVSS 4.3) vulnerability affecting gogs.io/gogs, gogs (gogits).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.8% of all vulnerabilities.
- Fix: update to 0.5.8 or later.
| Package | Affected versions | Patched versions |
|---|
| gogs.io/gogs Go | ≥ 0.3.1, < 0.5.8
| 0.5.8
|
| gogs | = 0.3.1-9= 0.4.1= 0.4.2= 0.5.0= 0.5.2≤ 0.5.5
| No fix yet |
Description
Cross-site scripting (XSS) vulnerability in models/issue.go in Gogs (aka Go Git Service) 0.3.1-9 through 0.5.x before 0.5.8 allows remote attackers to inject arbitrary web script or HTML via the text parameter to api/v1/markdown.
NVD description
Cross-site scripting (XSS) vulnerability in models/issue.go in Gogs (aka Go Git Service) 0.3.1-9 through 0.5.x before 0.5.8 allows remote attackers to inject arbitrary web script or HTML via the text parameter to api/v1/markdown.
More vulnerabilities in gogs.io/gogs
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free