In short
- CVE-2014-9462 is a HIGH (CVSS 7.5) vulnerability affecting mercurial, mercurial (mercurial).
- Chance of exploitation in the next 30 days (EPSS): 4.2%, higher than 90.9% of all vulnerabilities.
- Fix: update to 3.2.4 or later.
| Package | Affected versions | Patched versions |
|---|
| mercurial PyPI | < 3.2.4
| 3.2.4
|
| mercurial | ≤ 3.2.3
| No fix yet |
Description
The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.
NVD description
The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free