In short
- CVE-2014-9682 is a CRITICAL (CVSS 10.0) vulnerability affecting dns-sync (dns-sync project), dns-sync.
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.7% of all vulnerabilities.
- Fix: update to 0.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| dns-sync | ≤ 0.1.0
| No fix yet |
| dns-sync npm | < 0.1.1
| 0.1.1
|
Description
The dns-sync module before 0.1.1 for node.js allows context-dependent attackers to execute arbitrary commands via shell metacharacters in the first argument to the resolve API function.
NVD description
The dns-sync module before 0.1.1 for node.js allows context-dependent attackers to execute arbitrary commands via shell metacharacters in the first argument to the resolve API function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free