In short
- CVE-2014-9706 is a HIGH (CVSS 7.5) vulnerability affecting dulwich, dulwich (dulwich project).
- Chance of exploitation in the next 30 days (EPSS): 5.0%, higher than 92.3% of all vulnerabilities.
- Fix: update to 0.9.10, 0.9.9 or later.
| Package | Affected versions | Patched versions |
|---|
| dulwich PyPI | < 0.9.10< 0.9.9
| 0.9.100.9.9
|
| dulwich | ≤ 0.9.8
| No fix yet |
Description
The build_index_from_tree function in index.py in Dulwich versions 0.9.9 and below allows remote attackers to execute arbitrary code via a commit with a directory path starting with .git/, which is not properly handled when checking out a working tree.
NVD description
The build_index_from_tree function in index.py in Dulwich before 0.9.9 allows remote attackers to execute arbitrary code via a commit with a directory path starting with .git/, which is not properly handled when checking out a working tree.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free