In short
- CVE-2014-9720 is a MEDIUM (CVSS 6.5) vulnerability affecting tornado, tornado (tornadoweb).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.8% of all vulnerabilities.
- Fix: update to 3.2.2 or later.
| Package | Affected versions | Patched versions |
|---|
| tornado PyPI | < 3.2.2
| 3.2.2
|
| tornado | < 3.2.2
| 3.2.2
|
Description
Tornado before 3.2.2 sends arbitrary responses that contain a fixed CSRF token and may be sent with HTTP compression, which makes it easier for remote attackers to conduct a BREACH attack and determine this token via a series of crafted requests.
NVD description
Tornado before 3.2.2 sends arbitrary responses that contain a fixed CSRF token and may be sent with HTTP compression, which makes it easier for remote attackers to conduct a BREACH attack and determine this token via a series of crafted requests.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free