In short
- CVE-2015-0838 is a HIGH (CVSS 7.5) vulnerability affecting dulwich, dulwich (dulwich project).
- Chance of exploitation in the next 30 days (EPSS): 3.4%, higher than 88.8% of all vulnerabilities.
- Fix: update to 0.9.9 or later.
| Package | Affected versions | Patched versions |
|---|
| dulwich PyPI | < 0.9.9
| 0.9.9
|
| dulwich | ≤ 0.9.8
| No fix yet |
Description
Buffer overflow in the C implementation of the apply_delta function in _pack.c in Dulwich before 0.9.9 allows remote attackers to execute arbitrary code via a crafted pack file.
NVD description
Buffer overflow in the C implementation of the apply_delta function in _pack.c in Dulwich before 0.9.9 allows remote attackers to execute arbitrary code via a crafted pack file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free