In short
- CVE-2015-1819 is a MEDIUM (CVSS 5.0) vulnerability affecting nokogiri.
- Chance of exploitation in the next 30 days (EPSS): 6.3%, higher than 93.6% of all vulnerabilities.
- Fix: update to 1.6.6.4 or later.
| Package | Affected versions | Patched versions |
|---|
| nokogiri RubyGems | ≥ 1.6.6.0, < 1.6.6.4
| 1.6.6.4
|
Description
The xmlreader in libxml allows remote attackers to cause a denial of service (memory consumption) via crafted XML data, related to an XML Entity Expansion (XEE) attack.
NVD description
The xmlreader in libxml allows remote attackers to cause a denial of service (memory consumption) via crafted XML data, related to an XML Entity Expansion (XEE) attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free