In short
- CVE-2015-1820 is a CRITICAL (CVSS 9.8) vulnerability affecting rest-client, rest-client (rest-client project).
- Chance of exploitation in the next 30 days (EPSS): 4.3%, higher than 91.3% of all vulnerabilities.
- Fix: update to 1.8.0 or later.
| Package | Affected versions | Patched versions |
|---|
| rest-client RubyGems | ≥ 1.6.1.a, < 1.8.0
| 1.8.0
|
| rest-client | ≤ 1.7.3
| No fix yet |
Description
REST client for Ruby (aka rest-client) versions 1.6.1.a until 1.8.0 allow remote attackers to conduct session fixation attacks or obtain sensitive cookie information by leveraging passage of cookies set in a response to a redirect.
NVD description
REST client for Ruby (aka rest-client) before 1.8.0 allows remote attackers to conduct session fixation attacks or obtain sensitive cookie information by leveraging passage of cookies set in a response to a redirect.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free