In short
- CVE-2015-1828 is a MEDIUM (CVSS 5.9) vulnerability affecting http, http.rb (http.rb project).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.8% of all vulnerabilities.
- Fix: update to 0.7.3, 0.6.4 or later.
| Package | Affected versions | Patched versions |
|---|
| http RubyGems | ≥ 0.7.0, < 0.7.3< 0.6.4
| 0.7.30.6.4
|
| http.rb | ≤ 0.7.2
| No fix yet |
Description
The Ruby http gem before 0.6.4 and 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.
NVD description
The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free