In short
- CVE-2015-20108 is a CRITICAL (CVSS 9.8) vulnerability affecting ruby-saml, ruby-saml (onelogin).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.1% of all vulnerabilities.
- Fix: update to 1.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| ruby-saml RubyGems | < 1.0.0
| 1.0.0
|
| ruby-saml | < 1.0.0
| 1.0.0
|
Description
xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used.
NVD description
xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free