In short
- CVE-2015-2171 is a HIGH (CVSS 7.5) vulnerability affecting slim/slim, slim (slimframework).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.8% of all vulnerabilities.
- Fix: update to 2.6.0 or later.
| Package | Affected versions | Patched versions |
|---|
| slim/slim Packagist | < 2.6.0
| 2.6.0
|
| slim | ≤ 2.5.0
| No fix yet |
Description
Middleware/SessionCookie.php in Slim before 2.6.0 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via crafted session data.
NVD description
Middleware/SessionCookie.php in Slim before 2.6.0 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via crafted session data.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free