In short
- CVE-2015-2241 is a MEDIUM (CVSS 4.3) vulnerability affecting django, django (djangoproject).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.4% of all vulnerabilities.
- Fix: update to 1.8b2, 1.7.6 or later.
| Package | Affected versions | Patched versions |
|---|
| django PyPI | ≥ 1.8a1, < 1.8b2< 1.7.6
| 1.8b21.7.6
|
| django | = 1.8≤ 1.7.5
| No fix yet |
Description
Cross-site scripting (XSS) vulnerability in the contents function in admin/helpers.py in Django before 1.7.6 and 1.8 before 1.8b2 allows remote attackers to inject arbitrary web script or HTML via a model attribute in ModelAdmin.readonly_fields, as demonstrated by an @property.
NVD description
Cross-site scripting (XSS) vulnerability in the contents function in admin/helpers.py in Django before 1.7.6 and 1.8 before 1.8b2 allows remote attackers to inject arbitrary web script or HTML via a model attribute in ModelAdmin.readonly_fields, as demonstrated by a @property.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free