In short
- CVE-2015-3171 is a MEDIUM (CVSS 5.5) vulnerability affecting sosreport, sos (sos project).
- Chance of exploitation in the next 30 days (EPSS): 0.34%, higher than 28.0% of all vulnerabilities.
- Fix: update to 3.3 or later.
| Package | Affected versions | Patched versions |
|---|
| sosreport PyPI | ≥ 3.0< 3.3
| 3.3
|
| sos | = 3.2
| No fix yet |
Description
sosreport 3.2 uses weak permissions for generated sosreport archives, which allows local users with access to /var/tmp/ to obtain sensitive information by reading the contents of the archive.
NVD description
sosreport 3.2 uses weak permissions for generated sosreport archives, which allows local users with access to /var/tmp/ to obtain sensitive information by reading the contents of the archive.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free