In short
- CVE-2015-3225 is a MEDIUM (CVSS 5.0) vulnerability affecting rack, rack (rack project).
- Chance of exploitation in the next 30 days (EPSS): 8.0%, higher than 94.8% of all vulnerabilities.
- Fix: update to 1.4.6, 1.5.4, 1.6.2 or later.
| Package | Affected versions | Patched versions |
|---|
| rack RubyGems | ≥ 1.4.0, < 1.4.6≥ 1.5.0, < 1.5.4≥ 1.6.0, < 1.6.2
| 1.4.61.5.41.6.2
|
| rack | = 1.6.0= 1.6.1≤ 1.5.3
| No fix yet |
Description
lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote attackers to cause a denial of service (SystemStackError) via a request with a large parameter depth.
NVD description
lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote attackers to cause a denial of service (SystemStackError) via a request with a large parameter depth.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free