In short
- CVE-2015-3908 is a MEDIUM (CVSS 4.3) vulnerability affecting ansible, ansible (redhat).
- Chance of exploitation in the next 30 days (EPSS): 0.95%, higher than 61.2% of all vulnerabilities.
- Fix: update to 1.9.2 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible PyPI | < 1.9.2
| 1.9.2
|
| ansible | ≤ 1.9.1
| No fix yet |
Description
Ansible before 1.9.2 does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.
NVD description
Ansible before 1.9.2 does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free