In short
- CVE-2015-4082 is a MEDIUM (CVSS 6.5) vulnerability affecting attic, attic (attic project).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 85.0% of all vulnerabilities.
- Fix: update to 0.15 or later.
| Package | Affected versions | Patched versions |
|---|
| attic PyPI | < 0.15
| 0.15
|
| attic | ≤ 0.14
| No fix yet |
Description
attic before 0.15 does not confirm unencrypted backups with the user, which allows remote attackers with read and write privileges for the encrypted repository to obtain potentially sensitive information by changing the manifest type byte of the repository to "unencrypted / without key file".
NVD description
attic before 0.15 does not confirm unencrypted backups with the user, which allows remote attackers with read and write privileges for the encrypted repository to obtain potentially sensitive information by changing the manifest type byte of the repository to "unencrypted / without key file".
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free