In short
- CVE-2015-5147 is a HIGH (CVSS 7.5) vulnerability affecting redcarpet, redcarpet (redcarpet project).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 85.0% of all vulnerabilities.
- Fix: update to 3.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| redcarpet RubyGems | ≥ 3.3.0, < 3.3.2
| 3.3.2
|
| redcarpet | ≤ 3.3.1
| No fix yet |
Description
Stack-based buffer overflow in the header_anchor function in the HTML renderer in Redcarpet before 3.3.2 allows attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.
NVD description
Stack-based buffer overflow in the header_anchor function in the HTML renderer in Redcarpet before 3.3.2 allows attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free