In short
- CVE-2015-5688 is a MEDIUM (CVSS 5.0) vulnerability affecting geddy (geddyjs), geddy.
- Chance of exploitation in the next 30 days (EPSS): 9.4%, higher than 95.4% of all vulnerabilities.
- Fix: update to 13.0.8 or later.
| Package | Affected versions | Patched versions |
|---|
| geddy | = 13.0.7
| No fix yet |
| geddy npm | < 13.0.8
| 13.0.8
|
Description
Versions 13.0.8 and earlier of geddy are vulnerable to a directory traversal attack via URI encoded attack vectors.
Proof of Concept
http://localhost:4000/..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2fetc/passwd
Recommendation
Update geddy to version >= 13.0.8
NVD description
Directory traversal vulnerability in lib/app/index.js in Geddy before 13.0.8 for Node.js allows remote attackers to read arbitrary files via a ..%2f (dot dot encoded slash) in the PATH_INFO to the default URI.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free