In short
- CVE-2015-6497 is a HIGH (CVSS 8.8) vulnerability affecting magento/core, magento (magento).
- Chance of exploitation in the next 30 days (EPSS): 7.4%, higher than 94.4% of all vulnerabilities.
- Fix: update to 1.9.2.1, 1.14.2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| magento/core Packagist | < 1.9.2.1
| 1.9.2.1
|
| magento | < 1.14.2.1< 1.9.2.1
| 1.14.2.11.9.2.1
|
Description
The create function in app/code/core/Mage/Catalog/Model/Product/Api/V2.php in Magento Community Edition (CE) before 1.9.2.1 and Enterprise Edition (EE) before 1.14.2.1, when used with PHP before 5.4.24 or 5.5.8, allows remote authenticated users to execute arbitrary PHP code via the productData parameter to index.php/api/v2_soap.
NVD description
The create function in app/code/core/Mage/Catalog/Model/Product/Api/V2.php in Magento Community Edition (CE) before 1.9.2.1 and Enterprise Edition (EE) before 1.14.2.1, when used with PHP before 5.4.24 or 5.5.8, allows remote authenticated users to execute arbitrary PHP code via the productData parameter to index.php/api/v2_soap.
More vulnerabilities in magento/core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free