In short
- CVE-2015-7580 is a MEDIUM (CVSS 6.1) vulnerability affecting rails-html-sanitizer, html sanitizer (rubyonrails).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.4% of all vulnerabilities.
- Fix: update to 1.0.3 or later.
Description
Cross-site scripting (XSS) vulnerability in lib/rails/html/scrubbers.rb in the rails-html-sanitizer gem before 1.0.3 for Ruby on Rails 4.2.x and 5.x allows remote attackers to inject arbitrary web script or HTML via a crafted CDATA node.
NVD description
Cross-site scripting (XSS) vulnerability in lib/rails/html/scrubbers.rb in the rails-html-sanitizer gem before 1.0.3 for Ruby on Rails 4.2.x and 5.x allows remote attackers to inject arbitrary web script or HTML via a crafted CDATA node.
More vulnerabilities in rails-html-sanitizer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free