In short
- CVE-2015-7809 is a MEDIUM (CVSS 6.8) vulnerability affecting twig/twig, twig (symfony).
- Chance of exploitation in the next 30 days (EPSS): 3.4%, higher than 88.8% of all vulnerabilities.
- Fix: update to 1.20.0 or later.
| Package | Affected versions | Patched versions |
|---|
| twig/twig Packagist | < 1.20.0
| 1.20.0
|
| twig | ≤ 1.19.0
| No fix yet |
Description
The displayBlock function Template.php in Sensio Labs Twig before 1.20.0, when Sandbox mode is enabled, allows remote attackers to execute arbitrary code via the _self variable in a template.
NVD description
The displayBlock function Template.php in Sensio Labs Twig before 1.20.0, when Sandbox mode is enabled, allows remote attackers to execute arbitrary code via the _self variable in a template.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free