In short
- CVE-2015-8013 is a HIGH (CVSS 7.5) vulnerability affecting openpgpjs (openpgpjs), openpgp.
- Chance of exploitation in the next 30 days (EPSS): 3.9%, higher than 90.3% of all vulnerabilities.
- Fix: update to 1.3.0 or later.
| Package | Affected versions | Patched versions |
|---|
| openpgpjs | ≤ 1.2.0
| No fix yet |
| openpgp npm | < 1.3.0
| 1.3.0
|
Description
s2k.js in OpenPGP.js will decrypt arbitrary messages regardless of passphrase for crafted PGP keys which allows remote attackers to bypass authentication if message decryption is used as an authentication mechanism via a crafted symmetrically encrypted PGP message.
NVD description
s2k.js in OpenPGP.js will decrypt arbitrary messages regardless of passphrase for crafted PGP keys which allows remote attackers to bypass authentication if message decryption is used as an authentication mechanism via a crafted symmetrically encrypted PGP message.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free