In short
- CVE-2015-8371 is a HIGH (CVSS 8.8) vulnerability affecting composer/composer, composer (getcomposer).
- Chance of exploitation in the next 30 days (EPSS): 0.72%, higher than 54.0% of all vulnerabilities.
- Fix: update to 1.0.0 or later.
Description
Composer before 2016-02-10 allows cache poisoning from other projects built on the same host. This results in attacker-controlled code entering a server-side build process. The issue occurs because of the way that dist packages are cached. The cache key is derived from the package name, the dist type, and certain other data from the package repository (which may simply be a commit hash, and thus can be found by an attacker). Versions through 1.0.0-alpha11 are affected, and 1.0.0 is unaffected.
NVD description
Composer before 2016-02-10 allows cache poisoning from other projects built on the same host. This results in attacker-controlled code entering a server-side build process. The issue occurs because of the way that dist packages are cached. The cache key is derived from the package name, the dist type, and certain other data from the package repository (which may simply be a commit hash, and thus can be found by an attacker). Versions through 1.0.0-alpha11 are affected, and 1.0.0 is unaffected.
More vulnerabilities in composer/composer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free