In short
- CVE-2015-8797 is a MEDIUM (CVSS 6.1) vulnerability affecting org.apache.solr:solr-core, solr (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.3%, higher than 88.5% of all vulnerabilities.
- Fix: update to 5.3.1 or later.
Description
Cross-site scripting (XSS) vulnerability in webapp/web/js/scripts/plugins.js in the stats page in the Admin UI in Apache Solr before 5.3.1 allows remote attackers to inject arbitrary web script or HTML via the entry parameter to a plugins/cache URI.
NVD description
Cross-site scripting (XSS) vulnerability in webapp/web/js/scripts/plugins.js in the stats page in the Admin UI in Apache Solr before 5.3.1 allows remote attackers to inject arbitrary web script or HTML via the entry parameter to a plugins/cache URI.
More vulnerabilities in org.apache.solr:solr-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free