In short
- CVE-2015-8855 is a HIGH (CVSS 7.5) vulnerability affecting node.js (nodejs), semver.
- Chance of exploitation in the next 30 days (EPSS): 6.9%, higher than 94.1% of all vulnerabilities.
- Fix: update to 4.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| node.js | ≤ 4.3.1
| No fix yet |
| semver npm | ≥ 1.0.4, < 4.3.2
| 4.3.2
|
Description
Versions 4.3.1 and earlier of semver are affected by a regular expression denial of service vulnerability when extremely long version strings are parsed.
Recommendation
Update to version 4.3.2 or later
NVD description
The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free