In short
- CVE-2016-1000111 is a MEDIUM (CVSS 5.3) vulnerability affecting twisted, twisted (twisted).
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.3% of all vulnerabilities.
- Fix: update to 16.3.1 or later.
| Package | Affected versions | Patched versions |
|---|
| twisted PyPI | < 16.3.1
| 16.3.1
|
| twisted | < 16.3.1
| 16.3.1
|
Description
Twisted before 16.3.1 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect CGI applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect a CGI application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, aka an httpoxy issue.
NVD description
Twisted before 16.3.1 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect CGI applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect a CGI application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, aka an "httpoxy" issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free