In short
- CVE-2016-10075 is a HIGH (CVSS 7.8) vulnerability affecting tqdm, tqdm (tqdm project).
- Chance of exploitation in the next 30 days (EPSS): 0.44%, higher than 38.3% of all vulnerabilities.
- Fix: update to 4.11.2 or later.
| Package | Affected versions | Patched versions |
|---|
| tqdm PyPI | ≥ 4.10.0, < 4.11.2≥ 4.4.1, < 4.11.2< 4.11.2
| 4.11.2
|
| tqdm | = 4.10= 4.4.1
| No fix yet |
Description
The tqdm._version module in tqdm versions 4.4.1 and 4.10 allows local users to execute arbitrary code via a crafted repo with a malicious git log in the current working directory.
NVD description
The tqdm._version module in tqdm versions 4.4.1 and 4.10 allows local users to execute arbitrary code via a crafted repo with a malicious git log in the current working directory.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free