In short
- CVE-2016-10516 is a MEDIUM (CVSS 6.1) vulnerability affecting werkzeug, werkzeug (palletsprojects).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.6% of all vulnerabilities.
- Fix: update to 0.11.11 or later.
| Package | Affected versions | Patched versions |
|---|
| werkzeug PyPI | < 0.11.11
| 0.11.11
|
| werkzeug | < 0.11.11
| 0.11.11
|
Description
Cross-site scripting (XSS) vulnerability in the render_full function in debug/tbtools.py in the debugger in Pallets Werkzeug before 0.11.11 (as used in Pallets Flask and other products) allows remote attackers to inject arbitrary web script or HTML via a field that contains an exception message.
NVD description
Cross-site scripting (XSS) vulnerability in the render_full function in debug/tbtools.py in the debugger in Pallets Werkzeug before 0.11.11 (as used in Pallets Flask and other products) allows remote attackers to inject arbitrary web script or HTML via a field that contains an exception message.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free