In short
- CVE-2016-10543 is a MEDIUM (CVSS 5.3) vulnerability affecting call (call project), call.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.8% of all vulnerabilities.
- Fix: update to 3.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| call | ≥ 2.0.1, ≤ 3.0.1
| No fix yet |
| call npm | ≥ 2.0.1, < 3.0.2
| 3.0.2
|
Description
Affected versions of call do not validate empty parameters, which may result in a bypass of route validation rules.
Proof of Concept
Routing Scheme:
/api/{param}/{param2}/details
Triggering Request Path:
/api///
Recommendation
Update to version 3.0.2 or later.
NVD description
call is an HTTP router that is primarily used by the hapi framework. There exists a bug in call versions 2.0.1-3.0.1 that does not validate empty parameters, which could result in invalid input bypassing the route validation rules.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free