In short
- CVE-2016-10546 is a CRITICAL (CVSS 9.8) vulnerability affecting pouchdb (pouchdb), pouchdb.
- Chance of exploitation in the next 30 days (EPSS): 2.6%, higher than 85.2% of all vulnerabilities.
- Fix: update to 6.0.5 or later.
| Package | Affected versions | Patched versions |
|---|
| pouchdb | ≤ 6.0.4
| No fix yet |
| pouchdb npm | < 6.0.5
| 6.0.5
|
Description
Affected versions of pouchdb do not properly sandbox the code execution engine which executes the map/reduce functions for temporary views and design documents. Under certain circumstances, an attacker could uses this to run arbitrary code on the server.
Recommendation
Update to version 6.0.5 or later.
NVD description
An arbitrary code injection vector was found in PouchDB 6.0.4 and lesser via the map/reduce functions used in PouchDB temporary views and design documents. The code execution engine for this branch is not properly sandboxed and may be used to run arbitrary JavaScript as well as system commands.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free