In short
- CVE-2016-10551 is a CRITICAL (CVSS 9.8) vulnerability affecting waterline-sequel (balderdash), waterline-sequel.
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.2% of all vulnerabilities.
- Fix: update to 0.5.1 or later.
Description
Affected versions of waterline-sequel are vulnerable to SQL injection in cases where user input is passed into the like, contains, startsWith, or endsWith methods.
Recommendation
Upgrade to at least version 0.5.1
NVD description
waterline-sequel is a module that helps generate SQL statements for Waterline apps Any user input that goes into Waterline's `like`, `contains`, `startsWith`, or `endsWith` will end up in waterline-sequel with the potential for malicious code. A malicious user can input their own SQL statements in waterline-sequel 0.50 that will get executed and have full access to the database.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free