In short
- CVE-2016-10588 is a HIGH (CVSS 8.1) vulnerability affecting nw (nwjs), nw.
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.7% of all vulnerabilities.
- Fix: update to 0.23.6-1 or later.
| Package | Affected versions | Patched versions |
|---|
| nw | > 0.23.6-1
| No fix yet |
| nw npm | < 0.23.6-1
| 0.23.6-1
|
Description
Affected versions of nw insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running nw.
Recommendation
Update to version 0.23.6-1 or later.
NVD description
nw is an installer for nw.js. nw downloads zipped resources over HTTP, It may be possible to cause remote code execution (RCE) by swapping out the requested zip file with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free