In short
- CVE-2016-10744 is a MEDIUM (CVSS 6.1) vulnerability affecting select2 (select2), select2.
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.2% of all vulnerabilities.
- Fix: update to 4.0.6 or later.
| Package | Affected versions | Patched versions |
|---|
| select2 | ≤ 4.0.5
| No fix yet |
| select2 npm | < 4.0.6
| 4.0.6
|
Description
In Select2 through 4.0.5, as used in Snipe-IT and other products, rich selectlists allow XSS. This affects use cases with Ajax remote data loading when HTML templates are used to display listbox data.
NVD description
In Select2 through 4.0.5, as used in Snipe-IT and other products, rich selectlists allow XSS. This affects use cases with Ajax remote data loading when HTML templates are used to display listbox data.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free