In short
- CVE-2016-2164 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.openmeetings:openmeetings-parent, openmeetings (apache).
- Chance of exploitation in the next 30 days (EPSS): 7.0%, higher than 94.2% of all vulnerabilities.
- Fix: update to 3.1.1 or later.
Description
The (1) FileService.importFileByInternalUserId and (2) FileService.importFile SOAP API methods in Apache OpenMeetings before 3.1.1 improperly use the Java URL class without checking the specified protocol handler, which allows remote attackers to read arbitrary files by attempting to upload a file.
NVD description
The (1) FileService.importFileByInternalUserId and (2) FileService.importFile SOAP API methods in Apache OpenMeetings before 3.1.1 improperly use the Java URL class without checking the specified protocol handler, which allows remote attackers to read arbitrary files by attempting to upload a file.
More vulnerabilities in org.apache.openmeetings:openmeetings-parent
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free