In short
- CVE-2016-3105 is a HIGH (CVSS 8.8) vulnerability affecting mercurial, mercurial (mercurial).
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.2% of all vulnerabilities.
- Fix: update to 3.8, 3.8-rc or later.
| Package | Affected versions | Patched versions |
|---|
| mercurial PyPI | < 3.8< 3.8-rc
| 3.83.8-rc
|
| mercurial | ≤ 3.7.3
| No fix yet |
Description
The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.
NVD description
The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free