In short
- CVE-2016-3954 is a MEDIUM (CVSS 5.5) vulnerability affecting web2py, web2py (web2py).
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 72.4% of all vulnerabilities.
- Fix: update to 2.14.2 or later.
| Package | Affected versions | Patched versions |
|---|
| web2py PyPI | < 2.14.2
| 2.14.2
|
| web2py | < 2.14.2
| 2.14.2
|
Description
web2py before 2.14.2 allows remote attackers to obtain the session_cookie_key value via a direct request to examples/simple_examples/status. NOTE: this issue can be leveraged by remote attackers to execute arbitrary code using CVE-2016-3957.
NVD description
web2py before 2.14.2 allows remote attackers to obtain the session_cookie_key value via a direct request to examples/simple_examples/status. NOTE: this issue can be leveraged by remote attackers to execute arbitrary code using CVE-2016-3957.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free