In short
- CVE-2016-3958 is a HIGH (CVSS 7.8) vulnerability affecting stdlib, go (golang).
- Chance of exploitation in the next 30 days (EPSS): 0.40%, higher than 33.8% of all vulnerabilities.
- Fix: update to 1.6.1, 1.5.4 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.6.0-0, < 1.6.1< 1.5.4
| 1.6.11.5.4
|
| go | = 1.6≥ 1.5, < 1.5.4≥ 1.6, < 1.6.1
| 1.5.41.6.1
|
Description
Untrusted search path vulnerability on Windows related to LoadLibrary allows local users to gain privileges via a malicious DLL in the current working directory.
NVD description
Untrusted search path vulnerability in Go before 1.5.4 and 1.6.x before 1.6.1 on Windows allows local users to gain privileges via a Trojan horse DLL in the current working directory, related to use of the LoadLibrary function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free