In short
- CVE-2016-3959 is a HIGH (CVSS 7.5) vulnerability affecting stdlib, go (golang).
- Chance of exploitation in the next 30 days (EPSS): 4.4%, higher than 91.2% of all vulnerabilities.
- Fix: update to 1.6.1, 1.5.4 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.6.0-0, < 1.6.1< 1.5.4
| 1.6.11.5.4
|
| go | = 1.6≤ 1.5
| No fix yet |
Description
The Verify function in crypto/dsa passed certain parameters unchecked to the underlying big integer library, possibly leading to extremely long-running computations, which in turn makes Go programs vulnerable to remote denial of service attacks. Programs using HTTPS client certificates or the Go SSH server libraries are both exposed to this vulnerability.
NVD description
The Verify function in crypto/dsa/dsa.go in Go before 1.5.4 and 1.6.x before 1.6.1 does not properly check parameters passed to the big integer library, which might allow remote attackers to cause a denial of service (infinite loop) via a crafted public key to a program that uses HTTPS client certificates or SSH server libraries.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free