In short
- CVE-2016-4434 is a HIGH (CVSS 7.8) vulnerability affecting org.apache.tika:tika-core, tika (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.6%, higher than 89.4% of all vulnerabilities.
- Fix: update to 1.13 or later.
Description
Apache Tika before 1.13 does not properly initialize the XML parser or choose handlers, which might allow remote attackers to conduct XML External Entity (XXE) attacks via vectors involving (1) spreadsheets in OOXML files and (2) XMP metadata in PDF and other file formats, a related issue to CVE-2016-2175.
NVD description
Apache Tika before 1.13 does not properly initialize the XML parser or choose handlers, which might allow remote attackers to conduct XML External Entity (XXE) attacks via vectors involving (1) spreadsheets in OOXML files and (2) XMP metadata in PDF and other file formats, a related issue to CVE-2016-2175.
More vulnerabilities in org.apache.tika:tika-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free