In short
- CVE-2016-5386 is a HIGH (CVSS 8.1) vulnerability affecting stdlib, go (golang).
- Chance of exploitation in the next 30 days (EPSS): 5.2%, higher than 92.5% of all vulnerabilities.
- Fix: update to 1.6.3 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | < 1.6.3
| 1.6.3
|
| go | = 1.7≥ 1.0, < 1.6.3
| 1.6.3
|
Description
An input validation flaw in the CGI components allows the HTTP_PROXY environment variable to be set by the incoming Proxy header, which changes where Go by default proxies all outbound HTTP requests.
This environment variable is also used to set the outgoing proxy, enabling an attacker to insert a proxy into outgoing requests of a CGI program.
Read more about "httpoxy" here: https://httpoxy.org.
NVD description
The net/http package in Go through 1.6 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect CGI applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect a CGI application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, aka an "httpoxy" issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free