In short
- CVE-2016-5431 is a HIGH (CVSS 7.5) vulnerability affecting gree/jose, php jose (php jose project).
- Chance of exploitation in the next 30 days (EPSS): 0.95%, higher than 61.6% of all vulnerabilities.
- Fix: update to 2.2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| gree/jose Packagist | < 2.2.1
| 2.2.1
|
| php jose | < 2.2.1
| 2.2.1
|
Description
The PHP JOSE Library by Gree Inc. prior to 2.2.1 is vulnerable to key confusion/algorithm substitution in the JWS component resulting in bypassing the signature verification via crafted tokens.
NVD description
The PHP JOSE Library by Gree Inc. before version 2.2.1 is vulnerable to key confusion/algorithm substitution in the JWS component resulting in bypassing the signature verification via crafted tokens.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free