In short
- CVE-2016-6817 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.tomcat:tomcat, tomcat (apache).
- Chance of exploitation in the next 30 days (EPSS): 7.2%, higher than 94.3% of all vulnerabilities.
- Fix: update to 8.5.8, 9.0.0.M12 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.tomcat:tomcat Maven | ≥ 8.5.0, < 8.5.8≥ 9.0.0.M1, < 9.0.0.M12
| 8.5.89.0.0.M12
|
| tomcat | = 8.5.0= 8.5.1= 8.5.2= 8.5.3= 8.5.4= 8.5.5= 8.5.6= 9.0.0
| No fix yet |
Description
The HTTP/2 header parser in Apache Tomcat 9.0.0.M1 to 9.0.0.M11 and 8.5.0 to 8.5.6 entered an infinite loop if a header was received that was larger than the available buffer. This made a denial of service attack possible.
NVD description
The HTTP/2 header parser in Apache Tomcat 9.0.0.M1 to 9.0.0.M11 and 8.5.0 to 8.5.6 entered an infinite loop if a header was received that was larger than the available buffer. This made a denial of service attack possible.
More vulnerabilities in org.apache.tomcat:tomcat
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free