In short
- CVE-2016-8628 is a CRITICAL (CVSS 9.1) vulnerability affecting ansible, ansible (redhat).
- Chance of exploitation in the next 30 days (EPSS): 3.2%, higher than 88.2% of all vulnerabilities.
- Fix: update to 2.2.0.0, 2.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible PyPI | < 2.2.0.0
| 2.2.0.0
|
| ansible | < 2.2.0
| 2.2.0
|
Description
Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.
NVD description
Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free