In short
- CVE-2016-9177 is a HIGH (CVSS 7.5) vulnerability affecting com.sparkjava:spark-core, spark (sparkjava).
- Chance of exploitation in the next 30 days (EPSS): 5.1%, higher than 92.4% of all vulnerabilities.
- Fix: update to 2.5.2 or later.
Description
Directory traversal vulnerability in Spark 2.5 allows remote attackers to read arbitrary files via a .. (dot dot) in the URI.
NVD description
Directory traversal vulnerability in Spark 2.5 allows remote attackers to read arbitrary files via a .. (dot dot) in the URI.
More vulnerabilities in com.sparkjava:spark-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free